欢迎关注Hadoop、Spark、Flink、Hive、Hbase、Flume等大数据资料分享微信公共账号:iteblog_hadoop
  1. 文章总数:1078
  2. 浏览总数:14,717,215
  3. 评论:4201
  4. 分类目录:114 个
  5. 注册用户数:7085
  6. 最后更新:2019年12月4日
过往记忆博客公众号iteblog_hadoop
欢迎关注微信公众号:
iteblog_hadoop
大数据技术博客公众号bigdata_ai
开发爱好者社区:
bigdata_ai

Ubuntu安装依赖文件

  我们在安装软件的时候,有时会出现由于依赖的软件没有被安装,会导致软件安装的失败,其实我们可以用命令来安装依赖的软件,这里以Ubuntu为例进行说明。
  我在安装wps-office的时候,显示安装成功了,但是还是无法运行,后来才知道原来有些依赖的软件没有安装,导致wps无法运行。我们可以用户下面的命令查看依赖的软件:

iteblog@ubuntu:~/software$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
 wps-office:i386 : 依赖: libc6:i386 (>= 2.12) 但是它还没有被安装
                   依赖: libstdc++6:i386 (>= 4.5) 但是它还没有被安装
                   依赖: libfreetype6:i386 (>= 2.4) 但是它还没有被安装
                   依赖: libglu1-mesa:i386 但是它还没有被安装
                   依赖: libcups2:i386 但是它还没有被安装
                   推荐: ttf-mscorefonts-installer:i386
E: 不能满足依赖关系。不妨试一下 -f 选项。

  我们可以看到在上面的输出语句中有您也许需要运行“apt-get -f install”来修正上面的错误。,也就是可以通过这个来修复依赖软件。

iteblog@ubuntu:~/software$ sudo apt-get -f install

  这样就可以将依赖的软件安装好。

  目前wps只有32位版本的安装包,所以在安装之前先确认一下你系统是32位还是64位。

iteblog@ubuntu:~/software$ sudo dpkg --print-architecture
amd64
iteblog@ubuntu:~/software$ sudo dpkg --print-foreign-architectures
i386

  网上有教程说明如何在64系统运行32位的软件,这里就不介绍了,可以自己去搜索。

本博客文章除特别声明,全部都是原创!
转载本文请加上:转载自过往记忆(https://www.iteblog.com/)
本文链接: 【Ubuntu安装依赖文件】(https://www.iteblog.com/archives/1197.html)
喜欢 (2)
分享 (0)
发表我的评论
取消评论

表情
本博客评论系统带有自动识别垃圾评论功能,请写一些有意义的评论,谢谢!